In short
- CVE-2017-17068 is a HIGH (CVSS 7.5) vulnerability affecting auth0.js (auth0), auth0-js.
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 72.8% of all vulnerabilities.
- Fix: update to 8.12, 8.12.0 or later.
| Package | Affected versions | Patched versions |
|---|
| auth0.js | < 8.12
| 8.12
|
| auth0-js npm | < 8.12.0
| 8.12.0
|
Description
A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting versions < 8.12. This vulnerability allows an attacker to acquire authenticated users' tokens and invoke services on a user's behalf if the target site or application uses a popup callback page with auth0.popup.callback().
NVD description
A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting versions < 8.12. This vulnerability allows an attacker to acquire authenticated users' tokens and invoke services on a user's behalf if the target site or application uses a popup callback page with auth0.popup.callback().
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free