In short
- CVE-2017-2662 is a MEDIUM (CVSS 4.3) vulnerability affecting katello, katello (theforeman).
- Chance of exploitation in the next 30 days (EPSS): 0.94%, higher than 60.9% of all vulnerabilities.
- Fix: update to 3.17.0.rc1 or later.
| Package | Affected versions | Patched versions |
|---|
| katello RubyGems | < 3.17.0.rc1
| 3.17.0.rc1
|
| katello | = 3.4.5
| No fix yet |
Description
A flaw was found in Foreman's katello plugin version 3.4.5. After setting a new role to allow restricted access on a repository with a filter (filter set on the Product Name), the filter is not respected when the actions are done via hammer using the repository id.
NVD description
A flaw was found in Foreman's katello plugin version 3.4.5. After setting a new role to allow restricted access on a repository with a filter (filter set on the Product Name), the filter is not respected when the actions are done via hammer using the repository id.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free