In short
- CVE-2026-4324 is a MEDIUM (CVSS 5.4) vulnerability affecting katello.
- Chance of exploitation in the next 30 days (EPSS): 0.27%, higher than 19.6% of all vulnerabilities.
- Fix: update to 4.19.1 or later.
| Package | Affected versions | Patched versions |
|---|
| katello RubyGems | < 4.19.1
| 4.19.1
|
Description
A flaw was found in the Katello plugin for Red Hat Satellite. This vulnerability, caused by improper sanitization of user-provided input, allows a remote attacker to inject arbitrary SQL commands into the sort_by parameter of the /api/hosts/bootc_images API endpoint. This can lead to a Denial of Service (DoS) by triggering database errors, and potentially enable Boolean-based Blind SQL injection, which could allow an attacker to extract sensitive information from the database.
NVD description
A flaw was found in the Katello plugin for Red Hat Satellite. This vulnerability, caused by improper sanitization of user-provided input, allows a remote attacker to inject arbitrary SQL commands into the sort_by parameter of the /api/hosts/bootc_images API endpoint. This can lead to a Denial of Service (DoS) by triggering database errors, and potentially enable Boolean-based Blind SQL injection, which could allow an attacker to extract sensitive information from the database.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free