In short
- CVE-2026-12515 is a MEDIUM (CVSS 4.3) vulnerability affecting katello.
- Chance of exploitation in the next 30 days (EPSS): 0.22%, higher than 12.9% of all vulnerabilities.
- Fix: update to 4.21.0.rc1 or later.
| Package | Affected versions | Patched versions |
|---|
| katello RubyGems | < 4.21.0.rc1
| 4.21.0.rc1
|
Description
A flaw was found in Katello's of Red Hat Satellite. A content upload functionality where insufficient authorization checks in the ContentUploadsController allowed users with the edit_products permission to query content information for repositories outside the products they were authorized to manage. An authenticated attacker could exploit this issue to determine whether specific content exists within repositories that should otherwise be inaccessible. This issue does not allow unauthorized modification, import, or publication of content.
NVD description
A flaw was found in Katello's of Red Hat Satellite. A content upload functionality where insufficient authorization checks in the ContentUploadsController allowed users with the edit_products permission to query content information for repositories outside the products they were authorized to manage. An authenticated attacker could exploit this issue to determine whether specific content exists within repositories that should otherwise be inaccessible. This issue does not allow unauthorized modification, import, or publication of content.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free