In short
- CVE-2017-5635 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.nifi:nifi, nifi (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.3%, higher than 88.5% of all vulnerabilities.
- Fix: update to 1.1.2, 0.7.2 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.nifi:nifi Maven | ≥ 1.0.0, < 1.1.2< 0.7.2
| 1.1.20.7.2
|
| nifi | = 0.7.0= 0.7.1= 1.1.0= 1.1.1
| No fix yet |
Description
In Apache NiFi before 0.7.2 and 1.x before 1.1.2 in a cluster environment, if an anonymous user request is replicated to another node, the originating node identity is used rather than the "anonymous" user.
NVD description
In Apache NiFi before 0.7.2 and 1.x before 1.1.2 in a cluster environment, if an anonymous user request is replicated to another node, the originating node identity is used rather than the "anonymous" user.
More vulnerabilities in org.apache.nifi:nifi
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free