In short
- CVE-2017-5636 is a CRITICAL (CVSS 9.8) vulnerability affecting org.apache.nifi:nifi, nifi (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.6%, higher than 89.5% of all vulnerabilities.
- Fix: update to 1.1.2, 0.7.2 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.nifi:nifi Maven | ≥ 1.0.0, < 1.1.2< 0.7.2
| 1.1.20.7.2
|
| nifi | = 0.7.0= 0.7.1= 1.1.0= 1.1.1
| No fix yet |
Description
In Apache NiFi before 0.7.2 and 1.x before 1.1.2 in a cluster environment, the proxy chain serialization/deserialization is vulnerable to an injection attack where a carefully crafted username could impersonate another user and gain their permissions on a replicated request to another node.
NVD description
In Apache NiFi before 0.7.2 and 1.x before 1.1.2 in a cluster environment, the proxy chain serialization/deserialization is vulnerable to an injection attack where a carefully crafted username could impersonate another user and gain their permissions on a replicated request to another node.
More vulnerabilities in org.apache.nifi:nifi
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free