In short
- CVE-2017-7665 is a MEDIUM (CVSS 6.1) vulnerability affecting org.apache.nifi:nifi, nifi (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.5%, higher than 89.2% of all vulnerabilities.
- Fix: update to 1.3.0, 0.7.4 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.nifi:nifi Maven | ≥ 1.0.0, < 1.3.0< 0.7.4
| 1.3.00.7.4
|
| nifi | = 1.0.0= 1.0.1= 1.1.0= 1.1.1= 1.1.2= 1.2.0≤ 0.7.3
| No fix yet |
Description
In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms of XSS issues but were insufficient.
NVD description
In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms of XSS issues but were insufficient.
More vulnerabilities in org.apache.nifi:nifi
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free