In short
- CVE-2017-7686 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.ignite:ignite-core, ignite (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.0%, higher than 87.2% of all vulnerabilities.
- Fix: update to 2.1 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.ignite:ignite-core Maven | < 2.1
| 2.1
|
| ignite | = 1.0.0= 1.1.0= 1.2.0= 1.3.0= 1.4.0= 1.5.0= 1.6.0= 1.7.0= 1.8.0= 1.9.0= 2.0.0
| No fix yet |
Description
Apache Ignite 1.0.0-RC3 to 2.0 uses an update notifier component to update the users about new project releases that include additional functionality, bug fixes and performance improvements. To do that the component communicates to an external PHP server (http://ignite.run) where it needs to send some system properties like Apache Ignite or Java version. Some of the properties might contain user sensitive information.
NVD description
Apache Ignite 1.0.0-RC3 to 2.0 uses an update notifier component to update the users about new project releases that include additional functionality, bug fixes and performance improvements. To do that the component communicates to an external PHP server (http://ignite.run) where it needs to send some system properties like Apache Ignite or Java version. Some of the properties might contain user sensitive information.
More vulnerabilities in org.apache.ignite:ignite-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free