| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.ignite:ignite-core | ≥ 2.0.0, < 2.18.0 | 2.18.0 |
| ignite | ≥ 2.0.0, < 2.18.0 | 2.18.0 |
Relative Path Traversal vulnerability in Apache Ignite REST API.
Authenticated REST API users can read any file on the server with "cmd=log" command and a log path crafted in a certain way. This issue affects Apache Ignite: from 2.0.0 through 2.17.0.
Users are recommended to upgrade to version 2.18.0, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free