In short
- CVE-2018-8018 is a CRITICAL (CVSS 9.8) vulnerability affecting org.apache.ignite:ignite-core, ignite (apache).
- Chance of exploitation in the next 30 days (EPSS): 6.7%, higher than 93.9% of all vulnerabilities.
- Fix: update to 2.6, 2.5.3, 2.4.8 or later.
Description
Apache Ignite 2.5 and earlier serialization mechanism does not have a list of classes allowed for serialization/deserialization, which makes it possible to run arbitrary code when 3-rd party vulnerable classes are present in Ignite classpath. The vulnerability can be exploited if the one sends a specially prepared form of a serialized object to GridClientJdkMarshaller deserialization endpoint.
NVD description
In Apache Ignite before 2.4.8 and 2.5.x before 2.5.3, the serialization mechanism does not have a list of classes allowed for serialization/deserialization, which makes it possible to run arbitrary code when 3-rd party vulnerable classes are present in Ignite classpath. The vulnerability can be exploited if the one sends a specially prepared form of a serialized object to GridClientJdkMarshaller deserialization endpoint.
More vulnerabilities in org.apache.ignite:ignite-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free