In short
- CVE-2018-1000539 is a MEDIUM (CVSS 5.3) vulnerability affecting json-jwt, json-jwt (json-jwt project).
- Chance of exploitation in the next 30 days (EPSS): 0.77%, higher than 55.6% of all vulnerabilities.
- Fix: update to 1.9.4 or later.
| Package | Affected versions | Patched versions |
|---|
| json-jwt RubyGems | ≥ 0.5.1, < 1.9.4
| 1.9.4
|
| json-jwt | ≥ 0.5.0, < 1.9.4
| 1.9.4
|
Description
The json-jwt rubygem version >= 0.5.0 && < 1.9.4 contains a CWE-347: Improper Verification of Cryptographic Signature vulnerability in Decryption of AES-GCM encrypted JSON Web Tokens that can result in Attacker can forge a authentication tag. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 1.9.4 and later.
NVD description
Nov json-jwt version >= 0.5.0 && < 1.9.4 contains a CWE-347: Improper Verification of Cryptographic Signature vulnerability in Decryption of AES-GCM encrypted JSON Web Tokens that can result in Attacker can forge a authentication tag. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 1.9.4 and later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free