In short
- CVE-2019-18848 is a HIGH (CVSS 7.5) vulnerability affecting json-jwt, json-jwt (json-jwt project).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 69.7% of all vulnerabilities.
- Fix: update to 1.11.0 or later.
| Package | Affected versions | Patched versions |
|---|
| json-jwt RubyGems | < 1.11.0
| 1.11.0
|
| json-jwt | < 1.11.0
| 1.11.0
|
Description
The json-jwt gem before 1.11.0 for Ruby lacks an element count during the splitting of a JWE string.
NVD description
The json-jwt gem before 1.11.0 for Ruby lacks an element count during the splitting of a JWE string.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free