In short
- CVE-2023-51774 is a HIGH (CVSS 8.4) vulnerability affecting json-jwt, json-jwt (json-jwt project).
- Chance of exploitation in the next 30 days (EPSS): 0.23%, higher than 14.0% of all vulnerabilities.
- Fix: update to 1.16.6, 1.15.3.1 or later.
| Package | Affected versions | Patched versions |
|---|
| json-jwt RubyGems | ≥ 1.16.0, < 1.16.6< 1.15.3.1
| 1.16.61.15.3.1
|
| json-jwt | = 1.16.3
| No fix yet |
Description
The json-jwt (aka JSON::JWT) gem 1.16.x before 1.16.6, 1.15.x before 1.15.3.1 for Ruby sometimes allows bypass of identity checks via a sign/encryption confusion attack. For example, JWE can sometimes be used to bypass JSON::JWT.decode.
NVD description
The json-jwt (aka JSON::JWT) gem 1.16.3 for Ruby sometimes allows bypass of identity checks via a sign/encryption confusion attack. For example, JWE can sometimes be used to bypass JSON::JWT.decode.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free