In short
- CVE-2018-1002101 is a CRITICAL (CVSS 9.8) vulnerability affecting k8s.io/kubernetes, kubernetes (kubernetes).
- Chance of exploitation in the next 30 days (EPSS): 4.0%, higher than 90.5% of all vulnerabilities.
- Fix: update to 1.10.6, 1.11.2, 1.9.10 or later.
| Package | Affected versions | Patched versions |
|---|
| k8s.io/kubernetes Go | ≥ 1.10.0, < 1.10.6≥ 1.11.0, < 1.11.2≥ 1.9.0, < 1.9.10
| 1.10.61.11.21.9.10
|
| kubernetes | ≥ 1.10.0, ≤ 1.10.5≥ 1.11.0, ≤ 1.11.1≥ 1.9.0, ≤ 1.9.9
| No fix yet |
Description
In Kubernetes versions 1.9.0-1.9.9, 1.10.0-1.10.5, and 1.11.0-1.11.1, user input was handled insecurely while setting up volume mounts on Windows nodes, which could lead to command line argument injection.
Specific Go Packages Affected
k8s.io/kubernetes/pkg/util/mount
NVD description
In Kubernetes versions 1.9.0-1.9.9, 1.10.0-1.10.5, and 1.11.0-1.11.1, user input was handled insecurely while setting up volume mounts on Windows nodes, which could lead to command line argument injection.
More vulnerabilities in k8s.io/kubernetes
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free