In short
- CVE-2018-10931 is a CRITICAL (CVSS 9.8) vulnerability affecting cobbler, cobbler (cobbler project), satellite (redhat).
- Chance of exploitation in the next 30 days (EPSS): 68.1%, higher than 99.3% of all vulnerabilities.
- Fix: update to 3.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| cobbler PyPI | ≥ 2.6.0, < 3.0.0
| 3.0.0
|
| cobbler | ≥ 2.6.0, ≤ 2.6.11
| No fix yet |
| satellite | = 5.6= 5.7= 5.8
| No fix yet |
Description
It was found that cobbler 2.6.x exposed all functions from its CobblerXMLRPCInterface class over XMLRPC. A remote, unauthenticated attacker could use this flaw to gain high privileges within cobbler, upload files to arbitrary location in the context of the daemon.
NVD description
It was found that cobbler 2.6.x exposed all functions from its CobblerXMLRPCInterface class over XMLRPC. A remote, unauthenticated attacker could use this flaw to gain high privileges within cobbler, upload files to arbitrary location in the context of the daemon.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free