In short
- CVE-2018-11765 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.hadoop:hadoop-main, hadoop (apache).
- Chance of exploitation in the next 30 days (EPSS): 5.2%, higher than 92.5% of all vulnerabilities.
- Fix: update to 2.8.6, 2.9.3, 3.0.1 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.hadoop:hadoop-main Maven | ≥ 2.8.0, < 2.8.6≥ 2.9.0, < 2.9.3≥ 3.0.0-alpha2, < 3.0.1
| 2.8.62.9.33.0.1
|
| hadoop | = 3.0.0≥ 2.8.0, ≤ 2.8.5≥ 2.9.0, ≤ 2.9.2
| No fix yet |
Description
In Apache Hadoop versions 3.0.0-alpha2 to 3.0.0, 2.9.0 to 2.9.2, 2.8.0 to 2.8.5, any users can access some servlets without authentication when Kerberos authentication is enabled and SPNEGO through HTTP is not enabled.
NVD description
In Apache Hadoop versions 3.0.0-alpha2 to 3.0.0, 2.9.0 to 2.9.2, 2.8.0 to 2.8.5, any users can access some servlets without authentication when Kerberos authentication is enabled and SPNEGO through HTTP is not enabled.
More vulnerabilities in org.apache.hadoop:hadoop-main
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free