In short
- CVE-2018-8029 is a HIGH (CVSS 8.8) vulnerability affecting org.apache.hadoop:hadoop-main, hadoop (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.9%, higher than 90.3% of all vulnerabilities.
- Fix: update to 2.8.4, 2.9.2, 3.1.1 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.hadoop:hadoop-main Maven | ≥ 2.2.0, < 2.8.4≥ 2.9.0, < 2.9.2≥ 3.0.0, < 3.1.1
| 2.8.42.9.23.1.1
|
| hadoop | = 2.9.0= 2.9.1= 3.0.0≥ 2.2.0, ≤ 2.8.4≥ 3.0.1, ≤ 3.1.0
| No fix yet |
Description
In Apache Hadoop versions 3.0.0-alpha1 to 3.1.0, 2.9.0 to 2.9.1, and 2.2.0 to 2.8.4, a user who can escalate to yarn user can possibly run arbitrary commands as root user.
NVD description
In Apache Hadoop versions 3.0.0-alpha1 to 3.1.0, 2.9.0 to 2.9.1, and 2.2.0 to 2.8.4, a user who can escalate to yarn user can possibly run arbitrary commands as root user.
More vulnerabilities in org.apache.hadoop:hadoop-main
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free