In short
- CVE-2018-12544 is a CRITICAL (CVSS 9.8) vulnerability affecting io.vertx:vertx-core, vert.x (eclipse).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.3% of all vulnerabilities.
- Fix: update to 3.5.4 or later.
| Package | Affected versions | Patched versions |
|---|
| io.vertx:vertx-core Maven | ≥ 3.5.0, < 3.5.4
| 3.5.4
|
| vert.x | = 3.5.0= 3.5.1= 3.5.2= 3.5.3
| No fix yet |
Description
In version from 3.5.Beta1 to 3.5.3 of Eclipse Vert.x, the OpenAPI XML type validator creates XML parsers without taking appropriate defense against XML attacks. This mechanism is exclusively when the developer uses the Eclipse Vert.x OpenAPI XML type validator to validate a provided schema.
NVD description
In version from 3.5.Beta1 to 3.5.3 of Eclipse Vert.x, the OpenAPI XML type validator creates XML parsers without taking appropriate defense against XML attacks. This mechanism is exclusively when the developer uses the Eclipse Vert.x OpenAPI XML type validator to validate a provided schema.
More vulnerabilities in io.vertx:vertx-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free