In short
- CVE-2024-1300 is a MEDIUM (CVSS 5.4) vulnerability affecting io.vertx:vertx-core.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 64.7% of all vulnerabilities.
- Fix: update to 4.4.8, 4.5.3 or later.
| Package | Affected versions | Patched versions |
|---|
| io.vertx:vertx-core Maven | ≥ 4.3.4, < 4.4.8≥ 4.5.0, < 4.5.3
| 4.4.84.5.3
|
Description
A vulnerability in the Eclipse Vert.x toolkit causes a memory leak in TCP servers configured with TLS and SNI support. When processing an unknown SNI server name assigned the default certificate instead of a mapped certificate, the SSL context is erroneously cached in the server name map, leading to memory exhaustion. This flaw allows attackers to send TLS client hello messages with fake server names, triggering a JVM out-of-memory error.
NVD description
A vulnerability in the Eclipse Vert.x toolkit causes a memory leak in TCP servers configured with TLS and SNI support. When processing an unknown SNI server name assigned the default certificate instead of a mapped certificate, the SSL context is erroneously cached in the server name map, leading to memory exhaustion. This flaw allows attackers to send TLS client hello messages with fake server names, triggering a JVM out-of-memory error.
More vulnerabilities in io.vertx:vertx-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free