In short
- CVE-2024-1023 is a MEDIUM (CVSS 6.5) vulnerability affecting io.vertx:vertx-core.
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 76.6% of all vulnerabilities.
- Fix: update to 4.4.7, 4.5.2 or later.
| Package | Affected versions | Patched versions |
|---|
| io.vertx:vertx-core Maven | ≥ 4.4.5, < 4.4.7≥ 4.5.0, < 4.5.2
| 4.4.74.5.2
|
Description
A vulnerability in the Eclipse Vert.x toolkit results in a memory leak due to using Netty FastThreadLocal data structures. Specifically, when the Vert.x HTTP client establishes connections to different hosts, triggering the memory leak. The leak can be accelerated with intimate runtime knowledge, allowing an attacker to exploit this vulnerability. For instance, a server accepting arbitrary internet addresses could serve as an attack vector by connecting to these addresses, thereby accelerating the memory leak.
NVD description
A vulnerability in the Eclipse Vert.x toolkit results in a memory leak due to using Netty FastThreadLocal data structures. Specifically, when the Vert.x HTTP client establishes connections to different hosts, triggering the memory leak. The leak can be accelerated with intimate runtime knowledge, allowing an attacker to exploit this vulnerability. For instance, a server accepting arbitrary internet addresses could serve as an attack vector by connecting to these addresses, thereby accelerating the memory leak.
More vulnerabilities in io.vertx:vertx-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free