In short
- CVE-2018-1310 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.nifi:nifi, nifi (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.1%, higher than 87.8% of all vulnerabilities.
- Fix: update to 1.6.0 or later.
Description
Apache NiFi JMS Deserialization issue because of ActiveMQ client vulnerability. Malicious JMS content could cause denial of service. See ActiveMQ CVE-2015-5254 announcement for more information. The fix to upgrade the activemq-client library to 5.15.3 was applied on the Apache NiFi 1.6.0 release. Users running a prior 1.x release should upgrade to the appropriate release.
NVD description
Apache NiFi JMS Deserialization issue because of ActiveMQ client vulnerability. Malicious JMS content could cause denial of service. See ActiveMQ CVE-2015-5254 announcement for more information. The fix to upgrade the activemq-client library to 5.15.3 was applied on the Apache NiFi 1.6.0 release. Users running a prior 1.x release should upgrade to the appropriate release.
More vulnerabilities in org.apache.nifi:nifi
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free