In short
- CVE-2018-3715 is a MEDIUM (CVSS 6.5) vulnerability affecting glance (glance project), glance.
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 73.6% of all vulnerabilities.
- Fix: update to 3.0.4 or later.
| Package | Affected versions | Patched versions |
|---|
| glance | < 3.0.4
| 3.0.4
|
| glance npm | < 3.0.4
| 3.0.4
|
Description
Versions of glance before 3.0.4 are vulnerable to a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.
Recommendation
Update to version 3.0.4 or later.
NVD description
glance node module before 3.0.4 suffers from a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free