In short
- CVE-2018-3748 is a MEDIUM (CVSS 6.1) vulnerability affecting glance (glance project), glance.
- Chance of exploitation in the next 30 days (EPSS): 0.93%, higher than 60.7% of all vulnerabilities.
- Fix: update to 3.0.8 or later.
| Package | Affected versions | Patched versions |
|---|
| glance | = 3.0.5
| No fix yet |
| glance npm | < 3.0.8
| 3.0.8
|
Description
Versions of glance before 3.0.8 are vulnerable to Stored Cross-Site Scripting (XSS). This is only exploitable if the attacker is able to control the name of a file that is served by the glance package.
NVD description
There is a Stored XSS vulnerability in the glance node module versions <= 3.0.5. File name, which contains malicious HTML (eg. embedded iframe element or javascript: pseudo-protocol handler in <a> element) allows to execute JavaScript code against any user who opens a directory listing containing such crafted file name.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free