In short
- CVE-2022-25937 is a MEDIUM (CVSS 6.5) vulnerability affecting glance (glance project), glance.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.1% of all vulnerabilities.
- Fix: update to 3.0.9 or later.
| Package | Affected versions | Patched versions |
|---|
| glance | < 3.0.9
| 3.0.9
|
| glance npm | < 3.0.9
| 3.0.9
|
Description
Versions of the package glance before 3.0.9 are vulnerable to Directory Traversal that allows users to read files outside the public root directory. This is related to but distinct from the vulnerability reported in CVE-2018-3715.
NVD description
Versions of the package glance before 3.0.9 are vulnerable to Directory Traversal that allows users to read files outside the public root directory. This is related to but distinct from the vulnerability reported in [CVE-2018-3715](https://security.snyk.io/vuln/npm:glance:20180129).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free