In short
- CVE-2018-6558 is a MEDIUM (CVSS 6.5) vulnerability affecting github.com/google/fscrypt, fscrypt (google).
- Chance of exploitation in the next 30 days (EPSS): 0.62%, higher than 50.2% of all vulnerabilities.
- Fix: update to 0.2.4 or later.
Description
The pam_fscrypt module in fscrypt before 0.2.4 may incorrectly restore primary and supplementary group IDs to the values associated with the root user, which allows attackers to gain privileges via a successful login through certain applications that use Linux-PAM (aka pam).
NVD description
The pam_fscrypt module in fscrypt before 0.2.4 may incorrectly restore primary and supplementary group IDs to the values associated with the root user, which allows attackers to gain privileges via a successful login through certain applications that use Linux-PAM (aka pam).
More vulnerabilities in github.com/google/fscrypt
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free