In short
- CVE-2022-25328 is a HIGH (CVSS 7.3) vulnerability affecting github.com/google/fscrypt, fscrypt (google).
- Chance of exploitation in the next 30 days (EPSS): 0.20%, higher than 10.3% of all vulnerabilities.
- Fix: update to 0.3.3 or later.
Description
The bash_completion script for fscrypt allows injection of commands via crafted mountpoint paths, allowing privilege escalation under a specific set of circumstances. A local user who has control over mountpoint paths could potentially escalate their privileges if they create a malicious mountpoint path and if the system administrator happens to be using the fscrypt bash completion script to complete mountpoint paths. We recommend upgrading to version 0.3.3 or above
NVD description
The bash_completion script for fscrypt allows injection of commands via crafted mountpoint paths, allowing privilege escalation under a specific set of circumstances. A local user who has control over mountpoint paths could potentially escalate their privileges if they create a malicious mountpoint path and if the system administrator happens to be using the fscrypt bash completion script to complete mountpoint paths. We recommend upgrading to version 0.3.3 or above
More vulnerabilities in github.com/google/fscrypt
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free