In short
- CVE-2018-7212 is a MEDIUM (CVSS 5.3) vulnerability affecting sinatra, sinatra (sinatrarb).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 79.0% of all vulnerabilities.
- Fix: update to 2.0.1 or later.
| Package | Affected versions | Patched versions |
|---|
| sinatra RubyGems | ≥ 2.0.0.beta1, < 2.0.1
| 2.0.1
|
| sinatra | = 2.0.0= 2.0.1
| No fix yet |
Description
An issue was discovered in rack-protection/lib/rack/protection/path_traversal.rb in Sinatra 2.x before 2.0.1 on Windows. Path traversal is possible via backslash characters.
NVD description
An issue was discovered in rack-protection/lib/rack/protection/path_traversal.rb in Sinatra 2.x before 2.0.1 on Windows. Path traversal is possible via backslash characters.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free