In short
- CVE-2024-21510 is a MEDIUM (CVSS 5.4) vulnerability affecting sinatra.
- Chance of exploitation in the next 30 days (EPSS): 0.49%, higher than 42.4% of all vulnerabilities.
- Fix: update to 4.1.0 or later.
| Package | Affected versions | Patched versions |
|---|
| sinatra RubyGems | < 4.1.0
| 4.1.0
|
Description
Versions of the package sinatra from 0.0.0 are vulnerable to Reliance on Untrusted Inputs in a Security Decision via the X-Forwarded-Host (XFH) header. When making a request to a method with redirect applied, it is possible to trigger an Open Redirect Attack by inserting an arbitrary address into this header. If used for caching purposes, such as with servers like Nginx, or as a reverse proxy, without handling the X-Forwarded-Host header, attackers can potentially exploit Cache Poisoning or Routing-based SSRF.
NVD description
Versions of the package sinatra from 0.0.0 are vulnerable to Reliance on Untrusted Inputs in a Security Decision via the X-Forwarded-Host (XFH) header. When making a request to a method with redirect applied, it is possible to trigger an Open Redirect Attack by inserting an arbitrary address into this header. If used for caching purposes, such as with servers like Nginx, or as a reverse proxy, without handling the X-Forwarded-Host header, attackers can potentially exploit Cache Poisoning or Routing-based SSRF.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free