In short
- CVE-2022-29970 is a HIGH (CVSS 7.5) vulnerability affecting sinatra, sinatra (sinatrarb).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 82.0% of all vulnerabilities.
- Fix: update to 2.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| sinatra RubyGems | < 2.2.0
| 2.2.0
|
| sinatra | < 2.2.0
| 2.2.0
|
Description
Sinatra before 2.2.0 does not validate that the expanded path matches public_dir when serving static files.
NVD description
Sinatra before 2.2.0 does not validate that the expanded path matches public_dir when serving static files.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free