In short
- CVE-2019-12468 is a CRITICAL (CVSS 9.8) vulnerability affecting mediawiki/core, mediawiki (mediawiki).
- Chance of exploitation in the next 30 days (EPSS): 3.3%, higher than 88.6% of all vulnerabilities.
- Fix: update to 1.27.6, 1.30.2, 1.31.2, 1.32.2 or later.
| Package | Affected versions | Patched versions |
|---|
| mediawiki/core Packagist | ≥ 1.27.0, < 1.27.6≥ 1.30.0, < 1.30.2≥ 1.31.0, < 1.31.2≥ 1.32.0, < 1.32.2
| 1.27.61.30.21.31.21.32.2
|
| mediawiki | ≥ 1.27.0, ≤ 1.32.1
| No fix yet |
Description
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.27.0 through 1.32.1. Directly POSTing to Special:ChangeEmail would allow for bypassing re-authentication, allowing for potential account takeover.
NVD description
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.27.0 through 1.32.1. Directly POSTing to Special:ChangeEmail would allow for bypassing re-authentication, allowing for potential account takeover.
More vulnerabilities in mediawiki/core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free