In short
- CVE-2019-16552 is a MEDIUM (CVSS 5.4) vulnerability affecting com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger, gerrit trigger (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.62%, higher than 49.9% of all vulnerabilities.
- Fix: update to 2.30.2 or later.
Description
A missing permission check in Jenkins Gerrit Trigger Plugin 2.30.1 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified HTTP URL or SSH server using attacker-specified credentials, or determine the existence of a file with a given path on the Jenkins master.
NVD description
A missing permission check in Jenkins Gerrit Trigger Plugin 2.30.1 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified HTTP URL or SSH server using attacker-specified credentials, or determine the existence of a file with a given path on the Jenkins master.
More vulnerabilities in com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free