In short
- CVE-2020-10960 is a MEDIUM (CVSS 5.3) vulnerability affecting mediawiki/core, mediawiki (mediawiki).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.0% of all vulnerabilities.
- Fix: update to 1.31.7, 1.33.3, 1.34.1 or later.
| Package | Affected versions | Patched versions |
|---|
| mediawiki/core Packagist | ≥ 1.31.0, < 1.31.7≥ 1.33.0, < 1.33.3≥ 1.34.0, < 1.34.1
| 1.31.71.33.31.34.1
|
| mediawiki | < 1.34.1
| 1.34.1
|
Description
In MediaWiki before 1.34.1, users can add various Cascading Style Sheets (CSS) classes (which can affect what content is shown or hidden in the user interface) to arbitrary DOM nodes via HTML content within a MediaWiki page. This occurs because jquery.makeCollapsible allows applying an event handler to any Cascading Style Sheets (CSS) selector. There is no known way to exploit this for cross-site scripting (XSS).
NVD description
In MediaWiki before 1.34.1, users can add various Cascading Style Sheets (CSS) classes (which can affect what content is shown or hidden in the user interface) to arbitrary DOM nodes via HTML content within a MediaWiki page. This occurs because jquery.makeCollapsible allows applying an event handler to any Cascading Style Sheets (CSS) selector. There is no known way to exploit this for cross-site scripting (XSS).
More vulnerabilities in mediawiki/core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free