In short
- CVE-2020-7650 is a MEDIUM (CVSS 6.5) vulnerability affecting broker (synk), snyk-broker.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.4% of all vulnerabilities.
- Fix: update to 4.73.1 or later.
| Package | Affected versions | Patched versions |
|---|
| broker | ≥ 4.72.0, < 4.73.1
| 4.73.1
|
| snyk-broker npm | < 4.73.1
| 4.73.1
|
Description
All versions of snyk-broker after 4.72.0 including and before 4.73.1 are vulnerable to Arbitrary File Read. It allows arbitrary file reads to users with access to Snyk's internal network of any files ending in the following extensions: yaml, yml or json.
NVD description
All versions of snyk-broker after 4.72.0 including and before 4.73.1 are vulnerable to Arbitrary File Read. It allows arbitrary file reads to users with access to Snyk's internal network of any files ending in the following extensions: yaml, yml or json.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free