In short
- CVE-2020-7653 is a MEDIUM (CVSS 6.5) vulnerability affecting broker (synk), snyk-broker.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.4% of all vulnerabilities.
- Fix: update to 4.80.0 or later.
| Package | Affected versions | Patched versions |
|---|
| broker | < 4.80.0
| 4.80.0
|
| snyk-broker npm | < 4.80.0
| 4.80.0
|
Description
All versions of snyk-broker before 4.80.0 are vulnerable to Arbitrary File Read. It allows arbitrary file reads for users with access to Snyk's internal network by creating symlinks to match whitelisted paths.
NVD description
All versions of snyk-broker before 4.80.0 are vulnerable to Arbitrary File Read. It allows arbitrary file reads for users with access to Snyk's internal network by creating symlinks to match whitelisted paths.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free