In short
- CVE-2021-20842 is a MEDIUM (CVSS 6.5) vulnerability affecting ec-cube/ec-cube, ec-cube (ec-cube).
- Chance of exploitation in the next 30 days (EPSS): 0.55%, higher than 46.1% of all vulnerabilities.
- Fix: update to 2.17.2 or later.
| Package | Affected versions | Patched versions |
|---|
| ec-cube/ec-cube Packagist | ≥ 2.11.0, < 2.17.2
| 2.17.2
|
| ec-cube | ≥ 2.11.0, ≤ 2.17.1
| No fix yet |
Description
Cross-site request forgery (CSRF) vulnerability in EC-CUBE 2 series 2.11.0 to 2.17.1 allows a remote attacker to hijack the authentication of Administrator and delete Administrator via a specially crafted web page.
NVD description
Cross-site request forgery (CSRF) vulnerability in EC-CUBE 2 series 2.11.0 to 2.17.1 allows a remote attacker to hijack the authentication of Administrator and delete Administrator via a specially crafted web page.
More vulnerabilities in ec-cube/ec-cube
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free