In short
- CVE-2022-25355 is a MEDIUM (CVSS 5.3) vulnerability affecting ec-cube/ec-cube, ec-cube (ec-cube).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.1% of all vulnerabilities.
- Fix: update to 4.1.2, 3.0.18 or later.
| Package | Affected versions | Patched versions |
|---|
| ec-cube/ec-cube Packagist | ≥ 3.0.0, ≤ 3.0.18-p3≥ 4.0.0, < 4.1.2
| 4.1.2
|
| ec-cube | = 3.0.18≥ 3.0.0, < 3.0.18≥ 4.0.0, ≤ 4.1.1
| 3.0.18
|
Description
EC-CUBE 3.0.0 to 3.0.18-p3 and EC-CUBE 4.0.0 to 4.1.1 improperly handle HTTP Host header values, which may lead a remote unauthenticated attacker to direct the vulnerable version of EC-CUBE to send an Email with some forged reissue-password URL to EC-CUBE users.
NVD description
EC-CUBE 3.0.0 to 3.0.18-p3 and EC-CUBE 4.0.0 to 4.1.1 improperly handle HTTP Host header values, which may lead a remote unauthenticated attacker to direct the vulnerable version of EC-CUBE to send an Email with some forged reissue-password URL to EC-CUBE users.
More vulnerabilities in ec-cube/ec-cube
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free