In short
- CVE-2021-3115 is a HIGH (CVSS 7.5) vulnerability affecting toolchain, go (golang).
- Chance of exploitation in the next 30 days (EPSS): 6.9%, higher than 94.1% of all vulnerabilities.
- Fix: update to 1.15.7, 1.14.14 or later.
| Package | Affected versions | Patched versions |
|---|
| toolchain Go | ≥ 1.15.0-0, < 1.15.7< 1.14.14
| 1.15.71.14.14
|
| go | ≥ 1.15, < 1.15.7< 1.14.14
| 1.15.71.14.14
|
Description
The go command may execute arbitrary code at build time when using cgo on Windows. This can be triggered by running go get on a malicious module, or any other time the code is built.
NVD description
Go before 1.14.14 and 1.15.x before 1.15.7 on Windows is vulnerable to Command Injection and remote code execution when using the "go get" command to fetch modules that make use of cgo (for example, cgo can execute a gcc program from an untrusted download).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free