In short
- CVE-2021-32297 is a HIGH (CVSS 8.8) vulnerability affecting lief, lief (lief-project).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.3% of all vulnerabilities.
- Fix: update to 0.11.0, 0.11.5 or later.
| Package | Affected versions | Patched versions |
|---|
| lief PyPI | < 0.11.0< 0.11.5
| 0.11.00.11.5
|
| lief | ≤ 0.11.4
| No fix yet |
Description
An issue was discovered in LIEF prior to version 0.11.0. A heap-buffer-overflow exists in the function main located in pe_reader.c. It allows an attacker to cause code Execution.
NVD description
An issue was discovered in LIEF through 0.11.4. A heap-buffer-overflow exists in the function main located in pe_reader.c. It allows an attacker to cause code Execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free