In short
- CVE-2021-32855 is a MEDIUM (CVSS 6.1) vulnerability affecting vditor (b3log), vditor.
- Chance of exploitation in the next 30 days (EPSS): 0.58%, higher than 47.9% of all vulnerabilities.
- Fix: update to 3.8.7 or later.
| Package | Affected versions | Patched versions |
|---|
| vditor | < 3.8.7
| 3.8.7
|
| vditor npm | < 3.8.7
| 3.8.7
|
Description
Vditor is a browser-side Markdown editor. Versions prior to 3.8.7 are vulnerable to copy-paste cross-site scripting (XSS). For this particular type of XSS, the victim needs to be fooled into copying a malicious payload into the text editor. Version 3.8.7 contains a patch for this issue.
NVD description
Vditor is a browser-side Markdown editor. Versions prior to 3.8.7 are vulnerable to copy-paste cross-site scripting (XSS). For this particular type of XSS, the victim needs to be fooled into copying a malicious payload into the text editor. Version 3.8.7 contains a patch for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free