In short
- CVE-2022-24977 is a CRITICAL (CVSS 9.8) vulnerability affecting impresscms/impresscms, impresscms (impresscms).
- Chance of exploitation in the next 30 days (EPSS): 6.4%, higher than 93.6% of all vulnerabilities.
- Fix: update to 1.4.2 or later.
Description
ImpressCMS before 1.4.2 allows unauthenticated remote code execution via ...../// directory traversal in origName or imageName, leading to unsafe interaction with the CKEditor processImage.php script. The payload may be placed in PHP_SESSION_UPLOAD_PROGRESS when the PHP installation supports upload_progress.
NVD description
ImpressCMS before 1.4.2 allows unauthenticated remote code execution via ...../// directory traversal in origName or imageName, leading to unsafe interaction with the CKEditor processImage.php script. The payload may be placed in PHP_SESSION_UPLOAD_PROGRESS when the PHP installation supports upload_progress.
More vulnerabilities in impresscms/impresscms
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free