In short
- CVE-2022-46364 is a CRITICAL (CVSS 9.8) vulnerability affecting org.apache.cxf:cxf-core, cxf (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.4% of all vulnerabilities.
- Fix: update to 3.5.5, 3.4.10 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.cxf:cxf-core Maven | ≥ 3.5.0, < 3.5.5< 3.4.10
| 3.5.53.4.10
|
| cxf | ≥ 3.5.0, < 3.5.5< 3.4.10
| 3.5.53.4.10
|
Description
A SSRF vulnerability in parsing the href attribute of XOP:Include in MTOM requests in versions of Apache CXF before 3.5.5 and 3.4.10 allows an attacker to perform SSRF style attacks on webservices that take at least one parameter of any type.
NVD description
A SSRF vulnerability in parsing the href attribute of XOP:Include in MTOM requests in versions of Apache CXF before 3.5.5 and 3.4.10 allows an attacker to perform SSRF style attacks on webservices that take at least one parameter of any type.
More vulnerabilities in org.apache.cxf:cxf-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free