In short
- CVE-2025-23184 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.cxf:cxf-core, cxf (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.5% of all vulnerabilities.
- Fix: update to 3.6.5, 4.0.6, 3.5.10 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.cxf:cxf-core Maven | ≥ 3.6.0, < 3.6.5≥ 4.0.0, < 4.0.6< 3.5.10
| 3.6.54.0.63.5.10
|
| cxf | ≥ 3.6.0, < 3.6.5≥ 4.0.0, < 4.0.6< 3.5.10
| 3.6.54.0.63.5.10
|
Description
A potential denial of service vulnerability is present in versions of Apache CXF before 3.5.10, 3.6.5 and 4.0.6. In some edge cases, the CachedOutputStream instances may not be closed and, if backed by temporary files, may fill up the file system (it applies to servers and clients).
NVD description
A potential denial of service vulnerability is present in versions of Apache CXF before 3.5.10, 3.6.5 and 4.0.6. In some edge cases, the CachedOutputStream instances may not be closed and, if backed by temporary files, may fill up the file system (it applies to servers and clients).
More vulnerabilities in org.apache.cxf:cxf-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free