In short
- CVE-2023-26143 is a CRITICAL (CVSS 9.1) vulnerability affecting blamer (blamer project), blamer.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.4% of all vulnerabilities.
- Fix: update to 1.0.4 or later.
| Package | Affected versions | Patched versions |
|---|
| blamer | < 1.0.4
| 1.0.4
|
| blamer npm | < 1.0.4
| 1.0.4
|
Description
Versions of the blamer package before 1.0.4 are vulnerable to Arbitrary Argument Injection via the blameByFile() API. The library does not sanitize for user input or validate the given file path conforms to a specific schema, nor does it properly pass command-line flags to the git binary using the double-dash POSIX characters (--) to communicate the end of options.
NVD description
Versions of the package blamer before 1.0.4 are vulnerable to Arbitrary Argument Injection via the blameByFile() API. The library does not sanitize for user input or validate the given file path conforms to a specific schema, nor does it properly pass command-line flags to the git binary using the double-dash POSIX characters (--) to communicate the end of options.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free