In short
- CVE-2023-45277 is a HIGH (CVSS 7.5) vulnerability affecting org.yamcs:yamcs, yamcs (spaceapplications).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.6% of all vulnerabilities.
- Fix: update to 5.8.7 or later.
Description
Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.
NVD description
Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.
More vulnerabilities in org.yamcs:yamcs
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free