In short
- CVE-2023-45280 is a MEDIUM (CVSS 5.4) vulnerability affecting org.yamcs:yamcs, yamcs (spaceapplications).
- Chance of exploitation in the next 30 days (EPSS): 0.61%, higher than 49.1% of all vulnerabilities.
- Fix: update to 5.8.7 or later.
Description
Yamcs 5.8.6 allows XSS (issue 2 of 2). It comes with a Bucket as its primary storage mechanism. Buckets allow for the upload of any file. There's a way to upload an HTML file containing arbitrary JavaScript and then navigate to it. Once the user opens the file, the browser will execute the arbitrary JavaScript.
NVD description
Yamcs 5.8.6 allows XSS (issue 2 of 2). It comes with a Bucket as its primary storage mechanism. Buckets allow for the upload of any file. There's a way to upload an HTML file containing arbitrary JavaScript and then navigate to it. Once the user opens the file, the browser will execute the arbitrary JavaScript.
More vulnerabilities in org.yamcs:yamcs
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free