In short
- CVE-2023-4639 is a HIGH (CVSS 7.4) vulnerability affecting io.undertow:undertow-core.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 65.5% of all vulnerabilities.
- Fix: update to 2.3.11.Final, 2.2.30.Final or later.
| Package | Affected versions | Patched versions |
|---|
| io.undertow:undertow-core Maven | ≥ 2.3.0.Alpha1, < 2.3.11.Final< 2.2.30.Final
| 2.3.11.Final2.2.30.Final
|
Description
A flaw was found in Undertow, which incorrectly parses cookies with certain value-delimiting characters in incoming requests. This issue could allow an attacker to construct a cookie value to exfiltrate HttpOnly cookie values or spoof arbitrary additional cookie values, leading to unauthorized data access or modification. The main threat from this flaw impacts data confidentiality and integrity.
NVD description
A flaw was found in Undertow, which incorrectly parses cookies with certain value-delimiting characters in incoming requests. This issue could allow an attacker to construct a cookie value to exfiltrate HttpOnly cookie values or spoof arbitrary additional cookie values, leading to unauthorized data access or modification. The main threat from this flaw impacts data confidentiality and integrity.
More vulnerabilities in io.undertow:undertow-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free