In short
- CVE-2024-3884 is a HIGH (CVSS 7.5) vulnerability affecting io.undertow:undertow-core.
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 71.7% of all vulnerabilities.
- Fix: update to 2.3.21.Final, 2.4.0.Beta1, 2.2.39.Final or later.
| Package | Affected versions | Patched versions |
|---|
| io.undertow:undertow-core Maven | ≥ 2.3.0.Alpha1, < 2.3.21.Final≥ 2.4.0.Alpha1, < 2.4.0.Beta1< 2.2.39.Final
| 2.3.21.Final2.4.0.Beta12.2.39.Final
|
Description
A flaw was found in Undertow that can cause remote denial of service attacks. When the server uses the FormEncodedDataDefinition.doParse(StreamSourceChannel) method to parse large form data encoding with application/x-www-form-urlencoded, the method will cause an OutOfMemory issue. This flaw allows unauthorized users to cause a remote denial of service (DoS) attack.
NVD description
A flaw was found in Undertow that can cause remote denial of service attacks. When the server uses the FormEncodedDataDefinition.doParse(StreamSourceChannel) method to parse large form data encoding with application/x-www-form-urlencoded, the method will cause an OutOfMemory issue. This flaw allows unauthorized users to cause a remote denial of service (DoS) attack.
More vulnerabilities in io.undertow:undertow-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free