In short
- CVE-2024-4027 is a HIGH (CVSS 7.5) vulnerability affecting io.undertow:undertow-core.
- Chance of exploitation in the next 30 days (EPSS): 0.40%, higher than 34.4% of all vulnerabilities.
- Fix: update to 2.3.21.Final, 2.4.0.Beta1, 2.2.39.Final or later.
| Package | Affected versions | Patched versions |
|---|
| io.undertow:undertow-core Maven | ≥ 2.3.0.Alpha1, < 2.3.21.Final≥ 2.4.0.Alpha1, < 2.4.0.Beta1< 2.2.39.Final
| 2.3.21.Final2.4.0.Beta12.2.39.Final
|
Description
A flaw was found in Undertow. Servlets using a method that calls HttpServletRequestImpl.getParameterNames() can cause an OutOfMemoryError when the client sends a request with large parameter names. This issue can be exploited by an unauthorized user to cause a remote denial-of-service (DoS) attack.
NVD description
A flaw was found in Undertow. Servlets using a method that calls HttpServletRequestImpl.getParameterNames() can cause an OutOfMemoryError when the client sends a request with large parameter names. This issue can be exploited by an unauthorized user to cause a remote denial-of-service (DoS) attack.
More vulnerabilities in io.undertow:undertow-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free