In short
- CVE-2024-0793 is a HIGH (CVSS 7.7) vulnerability affecting k8s.io/kubernetes.
- Chance of exploitation in the next 30 days (EPSS): 0.59%, higher than 48.4% of all vulnerabilities.
- Fix: update to 1.27.0-alpha.1 or later.
| Package | Affected versions | Patched versions |
|---|
| k8s.io/kubernetes Go | < 1.27.0-alpha.1
| 1.27.0-alpha.1
|
Description
A flaw was found in kube-controller-manager. This issue occurs when the initial application of a HPA config YAML lacking a .spec.behavior.scaleUp block causes a denial of service due to KCM pods going into restart churn.
NVD description
A flaw was found in kube-controller-manager. This issue occurs when the initial application of a HPA config YAML lacking a .spec.behavior.scaleUp block causes a denial of service due to KCM pods going into restart churn.
More vulnerabilities in k8s.io/kubernetes
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free