In short
- CVE-2024-42468 is a HIGH (CVSS 7.5) vulnerability affecting org.openhab.ui.bundles:org.openhab.ui.cometvisu, openhab (openhab).
- Chance of exploitation in the next 30 days (EPSS): 0.81%, higher than 57.0% of all vulnerabilities.
- Fix: update to 4.2.1 or later.
Description
openHAB's CometVisuServlet is susceptible to an unauthenticated path traversal vulnerability.
Local files on the server can be requested via HTTP GET on the CometVisuServlet.
This vulnerability was discovered with the help of CodeQL's Uncontrolled data used in path expression query.
Impact
This issue may lead to Information Disclosure.
NVD description
openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. CometVisuServlet in versions prior to 4.2.1 is susceptible to an unauthenticated path traversal vulnerability. Local files on the server can be requested via HTTP GET on the CometVisuServlet. This issue may lead to information disclosure. Users should upgrade to version 4.2.1 of the CometVisu add-on of openHAB to receive a patch.
More vulnerabilities in org.openhab.ui.bundles:org.openhab.ui.cometvisu
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free